270799 Posts in 19739 Topics - by 1830 Members - Latest Member: Simplesimon

Hello Guest
Show unread posts since last visit.
Show new replies to your posts.

Author Topic: 1999 Dodge Stratus Gauge Cluster, A/C, Wipers do not work when Hot  (Read 1893 times)

Offline jvantassel80

  • Newbie
  • *
  • Posts: 1
  • Awards:
I am going to apologize in advance if this has been asked and answered previously. I am new at forums so bare with me. I bought this car a few weeks ago after my SUV was totaled.

Car runs great for the most part. Although... it seems like when the car gets hot (due to outside temp, not running temp) my Instrument Cluster (all gauges), Windshield Wipers will not work, and my A/c blows warm/hot air. There may be other issues that go along with this that I have not noticed yet. I cannot really drive the car the way it is currently acting in the Georgia Heat with those malfunctions.

Ive done plenty of reading/researching as has my husband trying to figure this mess out. So far we've checked all the fuses and cleaned connection as well as taken out the cluster and re-soldered all of the connections. Yet, as soon as the inside of the car heats up all of the gauges (and other mentioned issues) quit.

I called my local dealership and thought given how popular this issue is someone may be able to steer me in the right direction. HA! They want $95 to look at it and the guy I spoke with said it would cost around $1000 to fix. (Even though he had no clue what was going on with it)

I thank you in advance for taking the time to read and possibly even respond to my issue.

 

Questions, Concerns, Comments? Contact DOF Administrators
DodgeOwnerForums.com is not affiliated with Chrysler Group, LLC or Cummins, Inc