270793 Posts in 19737 Topics - by 1827 Members - Latest Member: marc solar

Hello Guest
Show unread posts since last visit.
Show new replies to your posts.

Author Topic: Help! I've got the HEMI tick on steroids and other wierd noise...  (Read 40 times)

Offline Oculus Ghost

  • Newbie
  • *
  • Posts: 2
  • Awards:
Hi all,

Hope everyone is doing great!  I searched around for anything related to my problem but mostly found zip.  Also hope I'm posting in the correct sub-forum, if not, please point the way  :up: .  I have a '06 SRT8 Mag and as far as I know it should be stock (I'm the 2nd owner).  Just a few days ago while at the body shop to get the rear bumper done it started making a ticking sound like that of the usual HEMI tick but much louder, it was accompanied by weird sound similar to a low pitched metal to metal grind (like when train wheels slip but low pitched).  I immediately shut down the engine.  We dug around and speculated about what it could be, and also removed the serpentine belt to take all the external moving parts out of the equation.  Oil level was OK and I personally change the oil every 3k miles and filter (Mobile1 filter and oil) inspecting for metal shavings as I do with all other vehicles I have or had. Once the bumper was done I took it back home on a flat bed.  After Googling I found many problems related to bad lifters ruining the cam shaft in the 5.7 (really similar engine to the 6.1) but nearly nothing on the 6.1. The problem there was the loud tick from locked out lifter rollers but also a misfire code and finally rockers with the lash way out of whack and worn cams. Mostly all also has the dreaded MDS.  I don't have the code or the lash problem (too early yet, maybe lucky).  Haven't reached the cam or lifters yet. Finding nothing to shed some light I'm tearing into the engine one step at a time.  I'm really new to HEMI engines having been a GM guy for the longest (feels like having been born in a bottle, in a corner, in a barn way out in the boonies! SHAME ON ME!!!), the first thing I notice once removing the head cover are these rings on the rocker shaft next to each rocker.  See pics below.  A few are way up nudged against the rocker while most are way off or sort of twisted letting the rocker to slip sideways a bit.  Their are also painted dots on the rocker assembly making me think I'm not the first in there.  Should their be a spring between one rocker and another like in other makes?  Should the rings be all nudged up against the rocker with maybe a specific clearance gap? If so, what is the gap spec? Can anyone throw me a bone here?  Big thanks in advance!   :punk: :helpsmilie:
« Last Edit: May 04, 2019, 05:02:48 pm by Oculus Ghost »

 

Questions, Concerns, Comments? Contact DOF Administrators
DodgeOwnerForums.com is not affiliated with Chrysler Group, LLC or Cummins, Inc